Варианты решения Ваших вопросов

  хостинг
<< Назад       Проблема с MySQL

Вопрос: После установки форума на движке Xenforo выскакивает такая ошибка, проблема в MySQL. Возможно ли обновить мне версию MySQL?
Вопрос: http://rust4life.ru/ An exception occurred: Argument 2 passed to XenForo_Application::mapMerge() must be an array, boolean given, called in /var/www/ryaninfo/data/www/rust4life.ru/library/XenForo/Dependencies/Public.php on line 309 and defined in /var/www/ryaninfo/data/www/rust4life.ru/library/XenForo/Application.php on line 1122 XenForo_Application::handlePhpError() in XenForo/Application.php at line 1122 XenForo_Application::mapMerge() in XenForo/Dependencies/Public.php at line 309 XenForo_Dependencies_Public->preRenderView() in XenForo/FrontController.php at line 561 XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158 XenForo_FrontController->run() in /var/www/ryaninfo/data/www/rust4life.ru/index.php at line 13
Ответ:

Добрый день.

А Вы не пробовали еще раз переустановить форум или скачать другую версию или вообще другой форум?

Вопрос: Этот движок я пробовал ставить трех версий 1.2.4, 1.2.5, 1.3.0 Везде та-же самая ошибка, дело в том что мне нужен именно этот движок и нехочеться ставить другие. Возможно ли решить эту проблему на серверном уровне?
Ответ:

Какую версию РНР требует ваш движок?

Вопрос: Каковы минимальные системные требования для XenForo? A: Требования следующие: - PHP 5.2.4+ - MySQL 5.0+ - PHP расширения: MySQLi, GD (с поддержкой JPEG), PCRE, SPL, SimpleXML, DOM, JSON, iconv, ctype - PHP safe_mode off Настоятельно рекомендуется использовать PHP optcode хеш, например, APC или Zend Optimiser. XenForo воспользуется преимуществом этих систем и значительно улучшит производительность.
Вопрос: Скрипт проверки показывает что все требования удовлетворены, но почитав на форумах все грешат на конфигурацию хостинга. Вот скрипт проверки http://rust4life.ru/xenforo_requirements_ru.php XenForo также требует установленного MySQL версии 5.0 или выше
Ответ:

По ссылке на ваш сайт показывает ошибку:

An exception occurred: Argument 2 passed to XenForo_Application::mapMerge() must be an array, boolean given, called in /var/www/ryaninfo/data/www/rust4life.ru/library/XenForo/Dependencies/Public.php on line 309 and defined in /var/www/ryaninfo/data/www/rust4life.ru/library/XenForo/Application.php on line 1122

  1. XenForo_Application::handlePhpError() in XenForo/Application.php at line 1122
  2. XenForo_Application::mapMerge() in XenForo/Dependencies/Public.php at line 309
  3. XenForo_Dependencies_Public->preRenderView() in XenForo/FrontController.php at line 561
  4. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  5. XenForo_FrontController->run() in /var/www/ryaninfo/data/www/rust4life.ru/index.php at line 13
Вопрос: Да, вот эта ошибка и выходит Вот тут пишут что проблема сервера http://xenforo.com/community/threads/unable-to-load-database-errors-execute-errors.30645/
Ответ:

mysqli у вас подключен

Вопрос: да, во время установки подключил и в нем добавились таблицы
Вопрос: Теперь при проверке пишет, что требования не удовлетворены. Требования не удовлетворены Нижеследующие требования для XenForo не удовлетворены. Пожалуйста, обратитесь к вашему хостеру за помощью. Необходимое расширение GD для PHP не найдено. Пожалуйста, попросите вашего хостера установить это расширение. Необходимое расширение для управления XML (DOM и SimpleXML) для PHP не найдено. Пожалуйста, попросите вашего хостера установить это расширение. XenForo также требует установленного MySQL версии 5.0 или выше. Пожалуйста, проверьте самостоятельно, соответствует ли ваша система этому требованию.
Ответ:

Ожидайте пожалуста, запрос отправлен администратору.

Вопрос: Долго?
Ответ:

В течении часа.

Вопрос: Хорошо, жду
Ответ:

Модули подключены:

dom
fileinfo
gd
json
mbstring
mcrypt
mysql
mysqli
pdo
pdo_mysql
pdo_sqlite
phar
sockets
xmlreader
zend_optimizer
zip

Вопрос: Теперь во время установки такая ошибка. Данные базы ввел правильно и несколько раз перепроверил. Error The following error occurred while connecting to the database: Access denied for user 'rust'@'localhost' (using password: YES) This indicates that your configuration information is not correct. Please check the values you have entered. If you are unsure what values are correct or how to proceed, please contact your host for help. These values are specific to your server.
Ответ:

Вы создали пользователя БД в ISP-панели?

Вопрос: Да
Вопрос: В базу заходит, но после любого клика выкидывает оттуда с сообщением Добро пожаловать в phpMyAdmin Ошибка #1045 - Access denied for user 'rust'@'localhost' (using password: YES)
Ответ:

Очистите кэш браузера и повторите вход.

Вопрос: Во время установки тоже самое The following error occurred while connecting to the database: Access denied for user 'rust'@'localhost' (using password: YES) This indicates that your configuration information is not correct. Please check the values you have entered. If you are unsure what values are correct or how to proceed, please contact your host for help. These values are specific to your server.
Ответ:

Вы можете пересоздать БД и пользователя и указать другой пароль?

Вопрос: Попробуйте сами запустить установку http://rust4life.ru/install и попробовать установить, после ввода данных базы данных эта ошибка выскочит имя базы rust имя пользователя rust пароль abdullaev
Вопрос: Хорошо сейчас попробую
Ответ:


ok


<< Назад